510 battery not working

Posted on 14.06.2018 by Malena
I tried manually opening battery saver in setting but it does not opens. The batteries are just not connecting, but they all work properly, as I can use them fine with another charger. I have the same battery and charger that came with the computer.
It was working when I left, so I'm not sure if it died from inactivity while I was gone it wasn't plugged in and I need to replace it, or if there's something else. Regards, Tap that kudos button if I helped If you find a post helpful and it answers your question, please mark it as an Accepted Solution. Original battery and power cords. I'm happy to buy a new battery if that's the problem, but is there any way to confir. But recently when i click on battery saver icon it does nothing. This is the normal behavior of the mouse. Plugin not charging is simple to fix with this free easy battery.
Whenever i used to click on the battery saver icon in the taskbar it used to start my battery saver. Hi, new member here with a problem. So at last i must say that i've checked a lot of ways and now my battery is still having problem. I've tried messing with the settings and taking the battery. Battery percentage shown before rather it turned off unexpectedly. And the LED does light up green when I plug it into a source.